Deprecated easyconfigs

Since EasyBuild v3.8.0, individual easyconfig files or particular (versions of) toolchains can be marked as deprecated.

Symptoms

Using an easyconfig file or toolchain that was marked as deprecated results in a warning message like:

WARNING: Deprecated functionality, will no longer work in v4.0: easyconfig file '/home/example/test.eb' is marked as deprecated:
This is an example message explaining why the easyconfig file was deprecated.
(see also http://easybuild.readthedocs.org/en/latest/Deprecated-easyconfigs.html)

Or, in case you are trying to use an easyconfig file or toolchain that was marked deprecated in a previous major version of EasyBuild:

ERROR: Failed to process easyconfig /home/example/test.eb: DEPRECATED (since v4.0) functionality used: easyconfig file '/home/example/test.eb' is marked as deprecated:
This is an example message explaining why the easyconfig file was deprecated.
(see also http://easybuild.readthedocs.org/en/latest/Deprecated-easyconfigs.html)

Reasons for deprecation

There are several possible reasons why a particular easyconfig file or toolchain was deprecated, some of which include:

  • old/obsolete versions of software or toolchain components
  • toolchains that are superseded by other toolchains
  • known installation problems that are hard to resolve (or not worth the effort to resolve)

Implications

Easyconfig files that are deprecated or which use a deprecated toolchain are not actively maintained, and are no longer included in the EasyBuild regression test (which means they may be broken by recent changes to the EasyBuild framework or relevant easyblocks).

In a future major version of EasyBuild, these easyconfig files will be archived (see also Archived easyconfigs).

Deprecated toolchains

Overview of deprecated toolchains:

gompi, goolf and goolfc toolchains

  • deprecated since: EasyBuild v3.8.0
  • will be archived in: EasyBuild v4.0.0

The goolf and goolfc toolchains have been deprecated, since they are superseded by the foss toolchain and fosscuda toolchains, respectively.

The foss* toolchains are equivalent to the goolf* toolchains, except that binutils is also included as a companion to GCC(core) in the foss* toolchains.

Versions of the gompi toolchain that were used as a subtoolchain for a deprecated toolchain have also been deprecated; this includes gompi toolchain versions that match 1.*.

ictce toolchain

  • deprecated since: EasyBuild v3.8.0
  • will be archived in: EasyBuild v4.0.0

The ictce toolchain has been deprecated, since it is superseded by the intel toolchain.

The ictce toolchain is equivalent to intel w.r.t. toolchain components, except that binutils is also included as a companion to GCC(core) (which serves as a base for the Intel compilers) in the intel toolchain.

Oldest versions of the iccifort, iimpi and intel toolchains

  • deprecated since: EasyBuild v3.8.0
  • will be archived in: EasyBuild v4.0.0

The oldest versions of the iccifort, iimpi and intel toolchain have been deprecated, since they are no longer considered relevant for recent systems.

More specifically, deprecated versions include:

  • iccifort versions older than 2016.1.150
  • iimpi versions older than 2016.01, except version 8.1.5-*
  • intel versions older than 2016a